Report site bugs here

Background Pony #321F
@Background Pony #62CA  
It seems to have something to do with the number of pages under any given history page. You’ll find it happening sporadically with anyone’s tag changes with numbers in the hundreds of thousands. Some of the more commonly edited tags have the same problem if you try to look at their change histories too. Reloading the page will usually get you through eventually.
Wiimeiser
Elements of Harmony - Had an OC in the 2022 Community Collab
Twinkling Balloon - Took part in the 2021 community collab.
My Little Pony - 1992 Edition
Friendship, Art, and Magic (2020) - Took part in the 2020 Community Collab
Dream Come True! - Participated in the MLP 9th Anniversary Event
Wallet After Summer Sale -
A Tale For The Ages - Celebrated MLP's 35th Anniversary and FiM's 8th Anniversary
An Artist Who Rocks - 100+ images under their artist tag
Not a Llama - Happy April Fools Day!
Artist -

(Foil Hat)
>>2395043 is missing the comments locked down tag, despite everything on the image being locked except hiding (not sure about votes/faves)
 
In fact, the end of derpibooru should probably imply comments locked down and follow through with everything related
Background Pony #62CA
@TheFinite  
Not a mod or dev, just posing some questions I think could be relevant:  
Does spoiler text show in other threads, too?  
Are you using any browser plugins or custom themes, eg. some kind of “night mode everywhere”, “reader mode” or similar? Or, accessibility settings to enhance text contrast? Because, the spoiler text hides itself by having the text the same color as the background, and something that changes colors would mess that up.  
Could you post a screenshot of what it looks like for you?
TheFinite
Wallet After Summer Sale -

Shiny Bug
  1. Spoiler text shows everywhere, even the example text above the texting box.  
  2. I do not think I am using any custom themes on my phone.
     
    Edit: It seems I have a light/dark mode setting on my phone that doesn’t seem to change much, but it did make the spoiler text work properly. It seems I did have my phone in ‘dark mode’ without realizing.
Background Pony #62CA
@TheFinite  
Ah, good to know. Glad you can get spoilers to work again.
 
I wonder whether the way spoilers are hidden ought to be revised to something more resilient to client-side interference.
JP
Elements of Harmony - Had an OC in the 2022 Community Collab
Non-Fungible Trixie -
Notoriously Divine Tagger - Consistently uploads images above and beyond the minimum tag requirements. And/or additionally, bringing over the original description from the source if the image has one. Does NOT apply to the uploader adding several to a dozen tags after originally uploading with minimum to bare tagging.
Fine Arts - Two hundred uploads with a score of over a hundred (Safe/Suggestive)
Kinship Through Differences - Celebrated the 11th anniversary of MLP:FIM!
Verified Pegasus - Show us your gorgeous wings!
Preenhub - We all know what you were up to this evening~
Twinkling Balloon - Took part in the 2021 community collab.
Ten years of changes - Celebrated the 10th anniversary of MLP:FiM!
My Little Pony - 1992 Edition

I miss the show so much
No matter what I do, I cannot remove the mispelled “socks (coat marking)” tag from >>2691313 (explicit) and add the correct “socks (coat markings)” tag. The changes just won’t save. I’ve tried it six times now, force-reloading the page between attempts multiple times. And I’ve tried removing the faulty tag first and then adding the correct one, and vice versa, but no dice. The changes just won’t save. Every other change seems to save just fine.
Background Pony #62CA
The reverse search API and the reverse search UI seem to give different results for the same input. For example, I was trying to find a user’s avatar: (suggestive) https://derpicdn.net/avatars/2015/06/25/19_21_51_343_FB_IMG_1432574832486.jpg
 
Performing the reverse search from https://derpibooru.org/search/reverse with a distance of 0.5 returns no matches. Performing the same, https://derpibooru.org/api/v1/json/search/reverse?url=https://derpicdn.net/avatars/2015/06/25/19_21_51_343_FB_IMG_1432574832486.jpg&distance=0.5 (as a POST, as required) returns 2 results (the image and a merged dupe).
 
Am I misunderstanding something fundamental? This doesn’t seem right.
 
P.S. Performing that search on the reverse UI page, even with the form’s maximum of 1, doesn’t find any matches.
Fair Use (Optimisitc Neighsayer)
Elements of Harmony - Had an OC in the 2022 Community Collab
Kinship Through Differences - Celebrated the 11th anniversary of MLP:FIM!
Twinkling Balloon - Took part in the 2021 community collab.
Wallet After Summer Sale -
The End wasn't The End - Found a new home after the great exodus of 2012

Excitedly Detached
Not sure if this is a bug, but every time I have attempted to post something today, I can’t and get this message:
 
Image width must be greater than 0  
Image height must be greater than 0
 
I have no idea how this is supposed to be fixed by the normal uploader/artist.
Ciaran
ラ・ゼッタ - For supporting the site
Tree of Harmony - Drew someone's OC for the 2022 Community Collab
Elements of Harmony - Had an OC in the 2022 Community Collab
Non-Fungible Trixie -
Magnificent Metadata Maniac - #1 Assistant
Kinship Through Differences - Celebrated the 11th anniversary of MLP:FIM!
Verified Pegasus - Show us your gorgeous wings!
Preenhub - We all know what you were up to this evening~
Philomena - For helping others attend the 2021 community collab
Twinkling Balloon - Took part in the 2021 community collab.

友情は魔法だ
@Fair Use (Optimisitc Neighsayer)  
Fascinating. I replicated it. Just a second …
 
There’s something unparsable in the JPG file. I converted it to a PNG and uploaded it here:
 

 
I made you the uploader. I wasn’t sure of all the tags, so please fix any tags I got wrong or missed, and correct the description if you wanted something else.
 
Ah … looks like there is something in the rotation that is causing the problem as well as the aspect ratios. The image looks like this when the EXIF data is not parsed:
 
full
 
Whatever tool you used to save the image saved ‘instructions’ for rotating and scaling the image rather than the actual ‘what you see is what you get’.
T6J2E5

Verified blank-flank
I’ve been using Firefox on my laptop for a while without issue on Derpibooru. I installed the latest Firefox on my Android phone this morning, and I can’t log in. The “sign in” button simply does nothing. The only other post I could find on here referring to this issue was from several months ago, but it looks like it was never answered. Is this a known issue? I’d really like to avoid going back to Chrome, if possible.
The Smiling Pony
Tree of Harmony - Drew someone's OC for the 2022 Community Collab
Elements of Harmony - Had an OC in the 2022 Community Collab
Non-Fungible Trixie -
Thread Starter - Report site bugs here
A Really Hyper Artist - 500+ images under their artist tag
Kinship Through Differences - Celebrated the 11th anniversary of MLP:FIM!
Verified Pegasus - Show us your gorgeous wings!
Preenhub - We all know what you were up to this evening~
Philomena - For helping others attend the 2021 community collab
Twinkling Balloon - Took part in the 2021 community collab.

Manually Breathing
@T6J2E5  
Can’t repro on FF 92.1.1 on an Android 10 with only uBlock as addon. If you have any addons, have you tried disabling them? Can you try setting the phone to horizontal, or switching to desktop mode?
T6J2E5

Verified blank-flank
@The Smiling Pony  
I don’t have any add-ons installed. Just tried both horizontal and desktop modes, but the sign in button still does nothing. I even tried turning off the privacy controls, but that was also ineffective. I’m not sure what repro means, but I am using Firefox version 92.1.1 (that’s what was in the Google Play Store).
Background Pony #62CA
The reverse search API and the reverse search UI seem to give different results for the same input.
Having tried another image (https://derpicdn.net/img/view/2021/9/19/2703806.png), my hypothesis is that the reverse search page always performs the search at 0.25 distance regardless of what is entered in the distance field.
 
Whether at 0.05, 0.25, or 0.75, that image finds 2 results through the reverse search page. However, through the API endpoint, 0.05 finds only 1 result, 0.25 finds 2, and 0.75 finds 10 (the cap, from what little I could understand from the philomena source).
T6J2E5

Verified blank-flank
@byte[]  
Hrm… Well, I can’t find the setting to enable/disable JavaScript in there, so I tried a different testing method. I can log into Gelbooru, and that requires both cookies and JavaScript. So, I know they’re both enabled. So far, it’s only Derpibooru that has this issue. I’ve logged into many other websites without a problem.
Background Pony #62CA
Sorry and/or you’re welcome, I broke the Markdown migration thread by using problematic syntax and now it throws a 500 error when viewing the last page. I’ve already reported it via, well, reports.
Interested in advertising on Derpibooru? Click here for information!
Ministry of Image - Fanfiction Printing

Derpibooru costs over $25 a day to operate - help support us financially!

Syntax quick reference: **bold** *italic* ||hide text|| `code` __underline__ ~~strike~~ ^sup^ %sub%

Detailed syntax guide